Remove the --install parameter when running aclocal. The --install argument is used to copy third-party files to the first -I directory. gnutls has -I m4 first, which would copy files to its local build directory. However, openwrt prepends the staging dir m4 directory, causing aclocal --install to copy an old definition of ax_code_coverage.m4 into the staging dir. If strace is built after gnutls, compilation will fail: Makefile:9303: *** missing separator. Stop. The version of ax_code_coverage.m4 that gets installed does not define @CODE_COVERAGE_RULES@. Removing the --install parameter in gnutls solves the issue. Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
25 lines
1,017 B
Diff
25 lines
1,017 B
Diff
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
|
From: Eneas U de Queiroz <cote2004-github@yahoo.com>
|
|
Date: Mon, 25 Oct 2021 08:49:21 -0300
|
|
Subject: Do not install m4 files
|
|
|
|
Do not use --install when calling aclocal. That flag instructs aclocal to
|
|
copy third-party files to the first -I directory. The intention here is to
|
|
copy files to the package build dir (m4). However, our toolchain prepends
|
|
the build-system's m4 dir to the list, causing the --install flag to
|
|
install an older version to the buildsystem m4 dir, causing failures in
|
|
other packages.
|
|
|
|
Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
|
|
|
|
--- a/Makefile.am
|
|
+++ b/Makefile.am
|
|
@@ -57,7 +57,7 @@ if ENABLE_DOC
|
|
SUBDIRS += doc
|
|
endif
|
|
|
|
-ACLOCAL_AMFLAGS = -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4 --install
|
|
+ACLOCAL_AMFLAGS = -I m4 -I src/libopts/m4 -I src/gl/m4 -I lib/unistring/m4
|
|
|
|
EXTRA_DIST = cfg.mk maint.mk CONTRIBUTING.md README.md LICENSE AUTHORS NEWS \
|
|
ChangeLog THANKS INSTALL.md RELEASES.md
|