pulseaudio-daemon depends on alsa-lib, which depends on @AUDIO_SUPPORT. Enables -full on platforms lacking AUDIO_SUPPORT. Simplified LDFLAGS slighly. Removed pointless ICU dependency. I managed to patch meson.build to fix iconv compilation. The original error was that without the header, it was prefixing the iconv check with __buildin_ , which does not work with uClibc-ng. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
414 B
Diff
11 lines
414 B
Diff
--- a/src/lib/icu/meson.build
|
|
+++ b/src/lib/icu/meson.build
|
|
@@ -18,7 +18,7 @@ if icu_dep.found()
|
|
'Init.cxx',
|
|
]
|
|
elif not get_option('iconv').disabled()
|
|
- have_iconv = compiler.has_function('iconv')
|
|
+ have_iconv = compiler.has_function('iconv', prefix : '#include <iconv.h>')
|
|
conf.set('HAVE_ICONV', have_iconv)
|
|
if not have_iconv and get_option('iconv').enabled()
|
|
error('iconv() not available')
|