OpenWrt toolchains already use correct CFLAGS for every ARM target There is no reason to use conservative CFLAGS now It also causes compile error with GCC 9.1.0 Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
11 lines
443 B
Diff
11 lines
443 B
Diff
--- a/make-linux.mk
|
|
+++ b/make-linux.mk
|
|
@@ -231,7 +231,7 @@ ifeq ($(ZT_OFFICIAL),1)
|
|
endif
|
|
|
|
# ARM32 hell -- use conservative CFLAGS
|
|
-ifeq ($(ZT_ARCHITECTURE),3)
|
|
+ifeq (0,3)
|
|
ifeq ($(shell if [ -e /usr/bin/dpkg ]; then dpkg --print-architecture; fi),armel)
|
|
override CFLAGS+=-march=armv5 -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
|
|
override CXXFLAGS+=-march=armv5 -mfloat-abi=soft -msoft-float -mno-unaligned-access -marm
|