The crude loop I wrote to come up with this changeset:
find -L package/feeds/packages/ -name patches | \
sed 's/patches$/refresh/' | sort | xargs make
Signed-off-by: Ilya Lipnitskiy <ilya.lipnitskiy@gmail.com>
(cherry picked from commit 5d8d4fbbcb
)
Signed-off-by: Jeffery To <jeffery.to@gmail.com>
24 lines
738 B
Diff
24 lines
738 B
Diff
From e18bcc65d5772e518c6496b439bad8a986f7e434 Mon Sep 17 00:00:00 2001
|
|
From: Rosen Penev <rosenp@gmail.com>
|
|
Date: Thu, 20 Jun 2019 15:18:19 -0700
|
|
Subject: [PATCH] configure: Fix iconv check for cross compilation
|
|
|
|
AC_CHECK_LIB is more friendly towards cross-compilation.
|
|
|
|
Added check for libiconv_open as that can be used when the libc lacks iconv.
|
|
---
|
|
configure.ac | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -59,7 +59,8 @@ if test "x$with_udev" != "xno"; then
|
|
[true])
|
|
fi
|
|
|
|
-AC_SEARCH_LIBS(iconv_open, iconv)
|
|
+AC_CHECK_LIB(iconv, iconv_open)
|
|
+AC_CHECK_LIB(iconv, libiconv_open)
|
|
|
|
# xxd (distributed with vim) is used in the testsuite
|
|
AC_CHECK_PROG([XXD_FOUND], [xxd], [yes])
|