packages/utils/sane-backends/patches/031-fix_uclibc.patch
Luiz Angelo Daros de Luca 275bc8edcf sane-backends: bump to 1.0.27
Fixes CVE-2017-6318

Patches where refreshed and the following removed:
- 020-fix_pieusb.patch: fixed upstream
- 030-musl.patch: accepted upstream

PS: there was no sane-backends 1.0.26

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
2017-05-31 00:18:23 -03:00

24 lines
754 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -280,6 +280,9 @@ AS_IF([test x != x$ALLOCA],
[LTALLOCA=`echo "$ALLOCA" | sed 's/\.o$//; s/\.obj$//'`.lo])
AC_SUBST(LTALLOCA)
+dnl Check mkostemp (missing in uclibc)
+AC_CHECK_FUNC(mkostemp)
+
dnl Define SOCKET_LIB, NSL_LIB, BIND_LIB, and RESOLV_LIB when required
dnl for functions we use.
AC_CHECK_FUNC(gethostbyaddr,, [AC_CHECK_LIB(bind, gethostbyaddr, BIND_LIB="-lbind")])
--- a/include/sane/config.h.in
+++ b/include/sane/config.h.in
@@ -229,6 +229,9 @@
/* Define to 1 if you have the `mkdir' function. */
#undef HAVE_MKDIR
+/* Define to 1 if you have a working `mkostemp' function. */
+#undef HAVE_MKOSTEMP
+
/* Define to 1 if you have a working `mmap' system call. */
#undef HAVE_MMAP