isc-dhcp uses system ar tool so build fails on Darwin build host. Embedded bind lib uses system ar and ranlib tools and fails on Darwin This patch explicitly specifies ar and ranlib tools for target build Signed-off-by: Sergey V. Lobanov <sergey@lobanov.in>
16 lines
771 B
Diff
16 lines
771 B
Diff
--- a/bind/Makefile.in
|
|
+++ b/bind/Makefile.in
|
|
@@ -56,7 +56,12 @@ bind1:
|
|
echo Configuring BIND libraries for DHCP. ; \
|
|
rm -rf ${cleandirs} ${cleanfiles} ; \
|
|
(cd ${bindsrcdir} && \
|
|
- ./configure ${bindconfig} > ${binddir}/configure.log); \
|
|
+ export CC=${CROSS_CC} AR=${TARGET_AR} RANLIB=${TARGET_RANLIB} && \
|
|
+ ./configure ${bindconfig} --disable-atomic \
|
|
+ --disable-kqueue --disable-epoll --disable-kqueue \
|
|
+ --disable-epoll --disable-devpoll --without-openssl \
|
|
+ --without-libxml2 --disable-threads --without-gssapi \
|
|
+ --without-randomdev > ${binddir}/configure.log); \
|
|
fi
|
|
|
|
atf:
|