packages/utils/attr/Makefile
Paul Fertser 0c10c224be treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.

The following temporary change was made to the core:

diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
 abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

 COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

 all:
 FORCE: ;

And this command used to fix affected packages:

for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
                              sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
  make package/$i/download
done

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
2023-04-21 22:46:58 +02:00

93 lines
2 KiB
Makefile

#
# Copyright (C) 2014-2016 OpenWrt.org
#
# This is free software, licensed under the GNU General Public License v2.
# See /LICENSE for more information.
#
include $(TOPDIR)/rules.mk
PKG_NAME:=attr
PKG_VERSION:=2.5.1
PKG_RELEASE:=1
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=http://git.savannah.nongnu.org/cgit/attr.git/snapshot
PKG_HASH:=69991b2fc5fe7917d996b05d5d4fe3c44d074c9d806dd263b14a42fab57bfc2f
PKG_MAINTAINER:=Maxim Storchak <m.storchak@gmail.com>
PKG_FIXUP:=autoreconf
PKG_INSTALL:=1
PKG_BUILD_PARALLEL:=1
include $(INCLUDE_DIR)/package.mk
define Package/attr/Default
TITLE:=Extended attributes (xattr) manipulation
URL:=http://savannah.nongnu.org/projects/attr
SUBMENU:=Filesystem
endef
define Package/attr/Default/description
Extended attributes support
endef
define Package/attr
$(call Package/attr/Default)
SECTION:=utils
CATEGORY:=Utilities
TITLE+=utils
LICENSE:=GPL-2.0-or-later
LICENSE_FILES:=doc/COPYING
DEPENDS:=+libattr
endef
define Package/libattr
$(call Package/attr/Default)
SECTION:=libs
CATEGORY:=Libraries
TITLE+=library
LICENSE:=LGPL-2.1-or-later
LICENSE_FILES:=doc/COPYING.LGPL
endef
define Package/libattr/description
$(call Package/attr/Default/description)
This package provides libattr
endef
define Package/attr/description
$(call Package/attr/Default/description)
This package provides xattr manipulation utilities
- attr
- getfattr
- setfattr
endef
CONFIGURE_ARGS += --enable-static --enable-shared
define Package/attr/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/* $(1)/usr/bin/
endef
define Package/libattr/install
$(INSTALL_DIR) $(1)/usr/lib
$(INSTALL_DIR) $(1)/etc
$(CP) $(PKG_INSTALL_DIR)/etc $(1)/
$(CP) $(PKG_INSTALL_DIR)/usr/lib/*.so* $(1)/usr/lib/
endef
define Package/attr/conffiles
/etc/xattr.conf
endef
define Build/InstallDev
$(INSTALL_DIR) $(1)/usr/include
$(INSTALL_DIR) $(1)/usr/lib/pkgconfig
$(CP) $(PKG_INSTALL_DIR)/usr/{include,lib} $(1)/usr/
endef
$(eval $(call BuildPackage,attr))
$(eval $(call BuildPackage,libattr))