Bump from 0.7.5 to 0.7.6. Upstream changelog: Fixed CVE-2018-10933 Added support for OpenSSL 1.1 Added SHA256 support for ssh_get_publickey_hash() Fixed config parsing Fixed random memory corruption when importing pubkeys Backported upstream patches since 0.7.6 to fix interactive authentication issues amongst other things: 9d5cf209 libcrypto: Fix memory leak in evp_final() 10397321 gssapi: Set correct state after sending GSSAPI_RESPONSE (select mechanism OID) 7ad80ba1 server: Fix compile error acb0e4f4 examples: Explicitly track auth state in samplesshd-kbdint 3fe7510b messages: Check that the requested service is 'ssh-connection' 734e3ce6 server: Set correct state after sending INFO_REQUEST (Kbd Interactive) e4c6d591 packet: Add missing break in ssh_packet_incoming_filter() f81ca616 misc: Add strndup implementation if not provides by the OS Refresh patches. Remove local backport for OpenSSL 1.1 support as is now in release Remove PKG_INSTALL & CMAKE vars that are defaulted anyway Add PKG_CPE_ID:=cpe:/a:libssh:libssh for CVE tracking Remove BROKEN tag as is no longer broken Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
35 lines
1 KiB
Diff
35 lines
1 KiB
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -35,10 +35,6 @@ include(DefineInstallationPaths)
|
|
include(DefineOptions.cmake)
|
|
include(CPackConfig.cmake)
|
|
|
|
-# disallow in-source build
|
|
-include(MacroEnsureOutOfSourceBuild)
|
|
-macro_ensure_out_of_source_build("${PROJECT_NAME} requires an out of source build. Please create a separate build directory and run 'cmake /path/to/${PROJECT_NAME} [options]' there.")
|
|
-
|
|
# search for libraries
|
|
if (WITH_ZLIB)
|
|
find_package(ZLIB REQUIRED)
|
|
--- a/ConfigureChecks.cmake
|
|
+++ b/ConfigureChecks.cmake
|
|
@@ -5,7 +5,6 @@ include(CheckFunctionExists)
|
|
include(CheckLibraryExists)
|
|
include(CheckTypeSize)
|
|
include(CheckCXXSourceCompiles)
|
|
-include(TestBigEndian)
|
|
|
|
set(PACKAGE ${APPLICATION_NAME})
|
|
set(VERSION ${APPLICATION_VERSION})
|
|
@@ -272,6 +271,8 @@ if (WITH_GSSAPI AND NOT GSSAPI_FOUND)
|
|
endif (WITH_GSSAPI AND NOT GSSAPI_FOUND)
|
|
|
|
# ENDIAN
|
|
-if (NOT WIN32)
|
|
- test_big_endian(WORDS_BIGENDIAN)
|
|
-endif (NOT WIN32)
|
|
+if (WITH_BIG_ENDIAN)
|
|
+ set(WORDS_BIGENDIAN 1)
|
|
+else (WITH_BIG_ENDIAN)
|
|
+ set(WORDS_BIGENDIAN 0)
|
|
+endif (WITH_BIG_ENDIAN)
|