packages/utils/setools/patches/030-remove-host-paths.patch
Eneas U de Queiroz 0aff79f29f
setools: Avoid using host libraries
This adds $STAGING_DIR to library search paths in setup.py, to avoid
picking up host libraries when linking.

Signed-off-by: Eneas U de Queiroz <cotequeiroz@gmail.com>
2021-02-24 21:41:15 -03:00

12 lines
376 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -79,7 +79,8 @@ class QtHelpCommand(Command):
# Library linkage
-lib_dirs = ['.', '/usr/lib64', '/usr/lib', '/usr/local/lib']
+owrt_staging_dir = os.environ["STAGING_DIR"]
+lib_dirs = ['.', owrt_staging_dir + '/usr/lib64', owrt_staging_dir + '/usr/lib', owrt_staging_dir + '/usr/local/lib' ]
include_dirs = []
with suppress(KeyError):