packages/utils/whois/patches/010-no-crypt.patch
Rosen Penev cfedca7360
whois: fix noidn patch
If no idn2 but idn is present, it picks it up. Just remove the whole
thing.

Refreshed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-11-29 20:03:07 -08:00

11 lines
403 B
Diff

--- a/Makefile
+++ b/Makefile
@@ -56,8 +56,6 @@ DEFS += -DHAVE_ICONV
endif
ifeq ($(shell $(PKG_CONFIG) --exists 'libxcrypt >= 4.1' || echo NO),)
-DEFS += -DHAVE_CRYPT_H -DHAVE_LINUX_CRYPT_GENSALT $(shell $(PKG_CONFIG) --cflags libcrypt)
-mkpasswd_LDADD += $(shell $(PKG_CONFIG) --libs libcrypt)
else ifdef HAVE_XCRYPT
DEFS += -DHAVE_XCRYPT_H -DHAVE_LINUX_CRYPT_GENSALT
mkpasswd_LDADD += -lxcrypt