Manually re-applied: 008-distutils-use-python-sysroot.patch 016-adjust-config-paths.patch Drop patch: 003-do-not-run-distutils-tests.patch There is now a configure option '--disable-test-modules' And seems we left the '_ctypes_test' around for quite some time. Dropped now. Refs: https://bugs.python.org/issue27640 https://bugs.python.org/issue43282 Drop patch: 013-getbuildinfo-date-time-source-date-epoch.patch Python build honors SOURCE_DATE_EPOCH pretty well now. Drop setuptools patches. Setuptools should be reproducible with Python 3.6+ according to a mention here: https://github.com/pypa/setuptools/pull/1690#issuecomment-536517456 It's time to let upstream fix Setuptools reproduce-ability. Drop patch: 010-do-not-add-rt-lib-dirs-when-cross-compiling.patch I can't seem to fully remember why it's there. And it seem to build fine without it. Drop patch: 015-abort-on-failed-modules.patch Python build supports a similar PYTHONSTRICTEXTENSIONBUILD=1 env-var option. Add patch: 026-openssl-feature-flags.patch We need to keep this in our tree for a while. See: https://bugs.python.org/issue45627 Backport patch: 027-bpo-43158-Use-configure-values-for-building-_uuid-ex.patch Link: https://github.com/python/cpython/pull/29353 Fixes the build for uuid C module. Add patch: 028-host-python-support-ssl-with-libressl.patch We need the _ssl module working on the host-side with LibreSSL for pip to work to download from https://pypi.org Refs: https://github.com/openwrt/openwrt/pull/4749 Add patch: 029-disable-deprecation-warning.patch Fixes apparmor build. The warning causes a configure error. Refreshed the rest of patches. Some old build-flags were removed. They don't seem to be necessary anymore. Split python3-uuid from python3-light. To better manage the libuuid library (if needed). Also, fixing the uuid C module build. Seems this was failing, and was falling back to using hashlib. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
22 lines
845 B
Diff
22 lines
845 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -15407,7 +15407,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
|
$as_echo "$ABIFLAGS" >&6; }
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
|
$as_echo_n "checking SOABI... " >&6; }
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $SOABI" >&5
|
|
$as_echo "$SOABI" >&6; }
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4798,7 +4798,7 @@ AC_SUBST(SOABI)
|
|
AC_MSG_CHECKING(ABIFLAGS)
|
|
AC_MSG_RESULT($ABIFLAGS)
|
|
AC_MSG_CHECKING(SOABI)
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
AC_MSG_RESULT($SOABI)
|
|
|
|
# Release and debug (Py_DEBUG) ABI are compatible, but not Py_TRACE_REFS ABI
|