packages/net/unbound/patches/010-configure-uname.patch
Stijn Segers 695e0dbaa4 unbound: update to 1.16.0
Signed-off-by: Stijn Segers <foss@volatilesystems.org>
2022-06-19 00:44:36 -06:00

14 lines
438 B
Diff

OpenWrt (modification):
Fix cross compile errors by inserting an environment variable for the
target. Use "uname" on host only if "UNAME" variable is empty.
--- a/configure.ac
+++ b/configure.ac
@@ -812,7 +812,7 @@ if test x_$ub_test_python != x_no; then
fi
fi
-if test "`uname`" = "NetBSD"; then
+if test "${UNAME:-`uname`}" = "NetBSD"; then
NETBSD_LINTFLAGS='"-D__RENAME(x)=" -D_NETINET_IN_H_'
AC_SUBST(NETBSD_LINTFLAGS)
fi