This required a bit work to get working, compared to other versions. So, some things have changed a bit more significantly. Some highlights: * there is no longer a pgen executable, seems this is now part of libpython; let's see what this means for us in the future * blake2 hash (from OpenSSL) detection needs some fixing; will upstream added patch 002-fix-blake2-detection.patch * removed all bpo patches; those should be fixed in upstream * some needed to be manually re-applied as stuff changed: - 001-enable-zlib.patch - file changed - 004-do-not-write-bytes-codes.patch - file changed - 015-abort-on-failed-modules.patch - variable was renamed cross_compiling -> CROSS_COMPILING * 017_lib2to3_fix_pyc_search.patch - the code changed, it does not seem to have the original problem with respect to file-extension, as there does not seem to be any special extension logic anymore there * 006-remove-multi-arch-and-local-paths.patch - dropped patch; I can't remember the full-details of this issue; it was something with Debian/Ubuntu's multi-arch stuff; it was probably added maybe due to some overzealous (on my part) thingy caused by some weird reports, that I could never solve; let's have this patch dropped and see * make package/python3/refresh to reduce fuzz for the rest Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
62 lines
2.1 KiB
Diff
62 lines
2.1 KiB
Diff
--- a/Lib/distutils/sysconfig.py
|
|
+++ b/Lib/distutils/sysconfig.py
|
|
@@ -445,6 +445,7 @@ def _init_posix():
|
|
platform=sys.platform,
|
|
multiarch=getattr(sys.implementation, '_multiarch', ''),
|
|
))
|
|
+ name = '_sysconfigdata'
|
|
_temp = __import__(name, globals(), locals(), ['build_time_vars'], 0)
|
|
build_time_vars = _temp.build_time_vars
|
|
global _config_vars
|
|
--- a/Lib/sysconfig.py
|
|
+++ b/Lib/sysconfig.py
|
|
@@ -344,6 +344,7 @@ def get_makefile_filename():
|
|
|
|
|
|
def _get_sysconfigdata_name():
|
|
+ return '_sysconfigdata'
|
|
return os.environ.get('_PYTHON_SYSCONFIGDATA_NAME',
|
|
'_sysconfigdata_{abi}_{platform}_{multiarch}'.format(
|
|
abi=sys.abiflags,
|
|
--- a/Makefile.pre.in
|
|
+++ b/Makefile.pre.in
|
|
@@ -1460,7 +1460,7 @@ libinstall: build_all $(srcdir)/Modules/
|
|
esac; \
|
|
done; \
|
|
done
|
|
- $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py \
|
|
+ $(INSTALL_DATA) `cat pybuilddir.txt`/_sysconfigdata*.py \
|
|
$(DESTDIR)$(LIBDEST); \
|
|
$(INSTALL_DATA) $(srcdir)/LICENSE $(DESTDIR)$(LIBDEST)/LICENSE.txt
|
|
ifeq (@COMPILE_ALL_TESTS@,yes)
|
|
@@ -1618,7 +1618,7 @@ sharedinstall: sharedmods
|
|
--install-scripts=$(BINDIR) \
|
|
--install-platlib=$(DESTSHARED) \
|
|
--root=$(DESTDIR)/
|
|
- -rm $(DESTDIR)$(DESTSHARED)/_sysconfigdata_$(ABIFLAGS)_$(MACHDEP)_$(MULTIARCH).py
|
|
+ -rm $(DESTDIR)$(DESTSHARED)/_sysconfigdata*.py
|
|
-rm -r $(DESTDIR)$(DESTSHARED)/__pycache__
|
|
|
|
# Here are a couple of targets for MacOSX again, to install a full
|
|
--- a/configure
|
|
+++ b/configure
|
|
@@ -15181,7 +15181,7 @@ else
|
|
fi
|
|
|
|
|
|
-if test x$PLATFORM_TRIPLET = x; then
|
|
+if true ; then
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4667,7 +4667,7 @@ fi
|
|
|
|
dnl define LIBPL after ABIFLAGS and LDVERSION is defined.
|
|
AC_SUBST(PY_ENABLE_SHARED)
|
|
-if test x$PLATFORM_TRIPLET = x; then
|
|
+if true ; then
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}"
|
|
else
|
|
LIBPL='$(prefix)'"/lib/python${VERSION}/config-${LDVERSION}-${PLATFORM_TRIPLET}"
|