packages/utils/passh/Makefile
Paul Fertser 0c10c224be treewide: remove AUTORELEASE
Automatically compute and substitute current values for all
$(AUTORELEASE) instances as this feature is deprecated and shouldn't be
used.

The following temporary change was made to the core:

diff --git a/rules.mk b/rules.mk
index 57d7995d4fa8..f16367de87a8 100644
--- a/rules.mk
+++ b/rules.mk
@@ -429,7 +429,7 @@ endef
 abi_version_str = $(subst -,,$(subst _,,$(subst .,,$(1))))

 COMMITCOUNT = $(if $(DUMP),0,$(call commitcount))
-AUTORELEASE = $(if $(DUMP),0,$(call commitcount,1))
+AUTORELEASE = $(if $(DUMP),0,$(shell sed -i "s/\$$(AUTORELEASE)/$(call commitcount,1)/" $(CURDIR)/Makefile))

 all:
 FORCE: ;

And this command used to fix affected packages:

for i in $(cd feeds/packages; git grep -l PKG_RELEASE:=.*AUTORELEASE | \
                              sed 's^.*/\([^/]*\)/Makefile^\1^';);
do
  make package/$i/download
done

Signed-off-by: Paul Fertser <fercerpav@gmail.com>
2023-04-21 22:46:58 +02:00

39 lines
953 B
Makefile

include $(TOPDIR)/rules.mk
PKG_NAME:=passh
PKG_VERSION:=1.0.1
PKG_RELEASE:=2
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
PKG_SOURCE_URL:=https://codeload.github.com/clarkwang/passh/tar.gz/v$(PKG_VERSION)?
PKG_HASH:=f6efc7127515b3716108fa28439caca561d16923404bb1a8f734b41340b3f14e
PKG_MAINTAINER:=Clark Wang <dearvoid@gmail.com>
PKG_LICENSE:=GPL-3.0-only
PKG_LICENSE_FILES:=LICENSE
include $(INCLUDE_DIR)/package.mk
define Package/passh
SECTION:=utils
CATEGORY:=Utilities
TITLE:=an sshpass alternative
URL:=https://github.com/clarkwang/passh
endef
define Package/passh/description
Passh is an sshpass alternative.
endef
define Build/Compile
$(TARGET_CC) $(TARGET_CFLAGS) -D_GNU_SOURCE -Wall $(TARGET_LDFLAGS) \
$(PKG_BUILD_DIR)/passh.c -o $(PKG_BUILD_DIR)/$(PKG_NAME)
endef
define Package/passh/install
$(INSTALL_DIR) $(1)/usr/bin
$(INSTALL_BIN) $(PKG_BUILD_DIR)/passh $(1)/usr/bin/
endef
$(eval $(call BuildPackage,passh))