packages/lang/python/twisted/patches/002-omit-tests.patch
Alexandru Ardelean 68312f49c0 python packages: move all things python under lang/python
I admit this may be be a bit aggressive, but the lang
folder is getting cluttered/filled up with Python, PHP, Perl,
Ruby, etc. packages.

Makes sense to try to group them into per-lang folders.

I took the Pythons.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
2017-05-17 16:51:14 +03:00

41 lines
1.4 KiB
Diff

diff --git a/setup.py b/setup.py
index e21ef70..a4d9ee8 100755
--- a/setup.py
+++ b/setup.py
@@ -55,13 +55,14 @@ def main(args):
setup_args = STATIC_PACKAGE_METADATA.copy()
setup_args.update(dict(
- packages=setuptools.find_packages(),
+ packages=setuptools.find_packages(exclude=["*.test", "*.test.*"]),
install_requires=requirements,
conditionalExtensions=getExtensions(),
entry_points={
'console_scripts': getConsoleScripts()
},
include_package_data=True,
+ exclude_package_data={'':['test/*']},
zip_safe=False,
extras_require=_EXTRAS_REQUIRE,
))
diff --git a/twisted/python/dist.py b/twisted/python/dist.py
index dfff9dc..a05b716 100644
--- a/twisted/python/dist.py
+++ b/twisted/python/dist.py
@@ -191,11 +191,11 @@ def getExtensions():
Get the C extensions used for Twisted.
"""
extensions = [
- ConditionalExtension(
- "twisted.test.raiser",
- ["twisted/test/raiser.c"],
- condition=lambda _: _isCPython
- ),
+ #ConditionalExtension(
+ # "twisted.test.raiser",
+ # ["twisted/test/raiser.c"],
+ # condition=lambda _: _isCPython
+ #),
ConditionalExtension(
"twisted.internet.iocpreactor.iocpsupport",
["twisted/internet/iocpreactor/iocpsupport/iocpsupport.c",