Domoticz 3.8153 introduced support for dzVents. Unfortunately this was broken by the 902_add-scripts-path, which attempts to make Domoticz more FHS-compliant instead of throwing everything under /opt/domoticz. The problem is that dzVents scripts added via the webinterface will be generated on the filesystem. With the 902_add-scripts-path patch, Domoticz tried to write this to "scriptsdir/dzVents/generated_scripts". As the scriptsdir contains scripts that come with upstream, and are not meant to be changed, this defaults to /usr/share/domoticz/scripts, which is not writeable, so Domoticz is unable to write the script to the filesystem. What is worse is that this silently fails. Fix this by moving the generated_scripts dir to "userdatadir/generated_scripts". The userdatadir defaults to /var/lib/domoticz, which is writeable. Additionally, since this patch does more than just adding the scripts path, rename it to something more appropriate. Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
39 lines
1.6 KiB
Diff
39 lines
1.6 KiB
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -521,20 +521,23 @@ else()
|
|
MESSAGE(FATAL_ERROR "cURL not found on your system, see install.txt how to get them installed. (for example 'sudo apt-get install curl libcurl4-openssl-dev')")
|
|
ENDIF(CURL_FOUND)
|
|
|
|
-find_path(LIBUSB_INCLUDE_DIR usb.h
|
|
- HINTS ${PC_LIBUSB_INCLUDEDIR} ${PC_LIBUSB_INCLUDE_DIRS})
|
|
-find_library(LIBUSB_LIBRARY NAMES usb
|
|
- HINTS ${PC_LIBUSB_LIBDIR} ${PC_LIBUSB_LIBRARY_DIRS})
|
|
-set(LIBUSB_LIBRARIES ${LIBUSB_LIBRARY})
|
|
+option(WITH_LIBUSB "Enable libusb support" NO)
|
|
+ if(WITH_LIBUSB)
|
|
+ find_path(LIBUSB_INCLUDE_DIR usb.h
|
|
+ HINTS ${PC_LIBUSB_INCLUDEDIR} ${PC_LIBUSB_INCLUDE_DIRS})
|
|
+ find_library(LIBUSB_LIBRARY NAMES usb
|
|
+ HINTS ${PC_LIBUSB_LIBDIR} ${PC_LIBUSB_LIBRARY_DIRS})
|
|
+ set(LIBUSB_LIBRARIES ${LIBUSB_LIBRARY})
|
|
|
|
-find_package_handle_standard_args(LIBUSB DEFAULT_MSG LIBUSB_LIBRARIES LIBUSB_INCLUDE_DIR)
|
|
-IF(LIBUSB_FOUND)
|
|
- MESSAGE(STATUS "LIBUSB found at: ${LIBUSB_LIBRARIES}")
|
|
- add_definitions(-DWITH_LIBUSB)
|
|
- target_link_libraries(domoticz ${LIBUSB_LIBRARIES})
|
|
-else()
|
|
- MESSAGE(STATUS "==== LibUSB not found, support for TE923/Voltcraft disabled!")
|
|
-ENDIF(LIBUSB_FOUND)
|
|
+ find_package_handle_standard_args(LIBUSB DEFAULT_MSG LIBUSB_LIBRARIES LIBUSB_INCLUDE_DIR)
|
|
+ IF(LIBUSB_FOUND)
|
|
+ MESSAGE(STATUS "LIBUSB found at: ${LIBUSB_LIBRARIES}")
|
|
+ add_definitions(-DWITH_LIBUSB)
|
|
+ target_link_libraries(domoticz ${LIBUSB_LIBRARIES})
|
|
+ else()
|
|
+ MESSAGE(STATUS "==== LibUSB not found, support for TE923/Voltcraft disabled!")
|
|
+ ENDIF(LIBUSB_FOUND)
|
|
+endif(WITH_LIBUSB)
|
|
|
|
#
|
|
# Find MD5/RMD160/SHA library
|