* update to 2021-11-22 upstream source * update patch file * update init script to preserve manual entries (fixes https://github.com/stangri/source.openwrt.melmac.net/issues/149) * update init script service_triggers Signed-off-by: Stan Grishin <stangri@melmac.ca>
15 lines
706 B
Diff
15 lines
706 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -21,9 +21,9 @@ if(NOT CMAKE_BUILD_TYPE)
|
|
message(STATUS "Setting build type to '${CMAKE_BUILD_TYPE}' as none was specified.")
|
|
endif()
|
|
|
|
-set(CMAKE_C_FLAGS "-Wall -Wextra --pedantic -Wno-strict-aliasing -Wno-variadic-macros")
|
|
-set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
|
|
-set(CMAKE_C_FLAGS_RELEASE "-O2")
|
|
+#set(CMAKE_C_FLAGS "-Wall -Wextra --pedantic -Wno-strict-aliasing -Wno-variadic-macros")
|
|
+#set(CMAKE_C_FLAGS_DEBUG "-g -DDEBUG")
|
|
+#set(CMAKE_C_FLAGS_RELEASE "-O2")
|
|
|
|
if ((CMAKE_C_COMPILER_ID MATCHES GNU AND CMAKE_C_COMPILER_VERSION VERSION_GREATER_EQUAL 9) OR
|
|
(CMAKE_C_COMPILER_ID MATCHES Clang AND CMAKE_C_COMPILER_VERSION VERSION_GREATER_EQUAL 10))
|