packages/net/radicale2/patches/110-disable-setup_requirements.patch
Daniel F. Dickinson 615fa96f9c radicale2: Update CalDAV/CardDAV server to v2.x
Radicale 2.x adds support for many new clients,
bug-fixes, etc so add v2 of this application.

We do it as a separate package for those not
ready to switch (it's not an straight inplace
upgrade from 1.x).

We do however CONFLICT with 1.x as they can't
be run side-by-side on the same host (without
containers for somesuch).

Signed-off-by: Daniel F. Dickinson <cshored@thecshore.com>
2019-01-09 01:35:18 -05:00

13 lines
550 B
Diff

Index: radicale2-python3-2.1.11/setup.py
===================================================================
--- radicale2-python3-2.1.11.orig/setup.py
+++ radicale2-python3-2.1.11/setup.py
@@ -67,7 +67,7 @@ setup(
package_data={"radicale": WEB_FILES},
entry_points={"console_scripts": ["radicale = radicale.__main__:run"]},
install_requires=["vobject>=0.9.6", "python-dateutil>=2.7.3"],
- setup_requires=pytest_runner,
+ setup_requires=[],
tests_require=tests_require,
extras_require={
"test": tests_require,