packages/net/quassel-irssi/patches/003-use-pkgconfig-ldflags-quasselc.patch
Rosen Penev 0f5737fe82 quassel-irc: Update to latest version
Now that the library has been updated, we can also update this.

Switched to codeload as we don't need the submodule anymore.

Various other Makefile consistency updates.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-01-05 19:19:14 -08:00

11 lines
384 B
Diff

--- a/core/Makefile
+++ b/core/Makefile
@@ -25,7 +25,7 @@ ifndef SYSTEM_QUASSELC
QUASSELC_FLAGS:=-Ilib
else
QUASSELC_FLAGS:=$(shell pkg-config --cflags quasselc)
- LDFLAGS += -lquasselc
+ LDFLAGS += $(shell pkg-config --libs quasselc)
endif
CFLAGS+=-std=gnu11 -Wall -Wextra -Werror -g $(IRSSI_CFLAGS) $(QUASSELC_FLAGS) -Wmissing-prototypes -Wmissing-declarations