Two patches were backported to fix issue openwrt/packages#12737 0002-compat-Fix-ipv6_dst_lookup-build-error.patch 0003-compat-Backport-ipv6_stub-change.patch One was deleted as it is now part of 2.11.3 0005-datapath-conntrack-fix-include-for-IP6_DEFRAG_CONNTR.patch Other patches refreshed Reported-by: Josef Schlehofer <pepe.schlehofer@gmail.com> Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
31 lines
1.2 KiB
Diff
31 lines
1.2 KiB
Diff
From c3bd9af7beb085b134235c80c03b96caf4063da4 Mon Sep 17 00:00:00 2001
|
|
From: Yousong Zhou <yszhou4tech@gmail.com>
|
|
Date: Mon, 16 Mar 2020 15:18:16 +0800
|
|
Subject: [PATCH] datapath: unexport LDFLAGS
|
|
|
|
OpenWrt build system will put "-specs=.../hardened-pie-ld.specs" into
|
|
LDFLAGS when building PIE binaries. However the "-specs" argument is
|
|
inteneded for "gcc" the driver while "ld" the linker when presented will
|
|
complain it as unrecognized error.
|
|
|
|
This can cause Kbuild error when building datapath kernel modules. The
|
|
issue should only happen when compiling against upstream kernel 4.14 and
|
|
earlier. Later ones should have been fixed with kernel upstream commit
|
|
d503ac531a5 ("kbuild: rename LDFLAGS to KBUILD_LDFLAGS")
|
|
|
|
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
|
|
---
|
|
datapath/linux/Makefile.in | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/datapath/linux/Makefile.in b/datapath/linux/Makefile.in
|
|
index efc1663e4..61fcaa67e 100644
|
|
--- a/datapath/linux/Makefile.in
|
|
+++ b/datapath/linux/Makefile.in
|
|
@@ -1,5 +1,6 @@
|
|
ifeq ($(KERNELRELEASE),)
|
|
# We're being called directly by running make in this directory.
|
|
+unexport LDFLAGS
|
|
include Makefile.main
|
|
else
|
|
# We're being included by the Linux kernel build system
|