Disable PCRE process searching to avoid linking against libprce, which would cause the build to fail due to a missing dependency. With the --without-pcre switch, build fails due to an undefined reference, so do it via CONFIGURE_VARS instead. Signed-off-by: Rosen Penev <rosenp@gmail.com> [disable PCRE process searching] Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
11 lines
503 B
Diff
11 lines
503 B
Diff
--- a/Makefile.top
|
|
+++ b/Makefile.top
|
|
@@ -87,7 +87,7 @@ LIBCURRENT = 30
|
|
LIBAGE = 0
|
|
LIBREVISION = 0
|
|
|
|
-LIB_LD_CMD = $(LIBTOOL) --mode=link $(LINKCC) $(CFLAGS) -rpath $(libdir) -version-info $(LIBCURRENT):$(LIBREVISION):$(LIBAGE) -o
|
|
+LIB_LD_CMD = $(LIBTOOL) --mode=link $(LINKCC) $(CFLAGS) -rpath $(libdir) $(LDFLAGS) -version-info $(LIBCURRENT):$(LIBREVISION):$(LIBAGE) -o
|
|
LIB_EXTENSION = la
|
|
LIB_VERSION =
|
|
LIB_LDCONFIG_CMD = $(LIBTOOL) --mode=finish $(INSTALL_PREFIX)$(libdir)
|