Switched to CMake. This allows getting rid of several patches and hacks. Added PKG_LICENSE information Rearranged some stuff for consistency between packages. Added some linked flags for smaller size. Saves around 500 bytes on MIPS. Signed-off-by: Rosen Penev <rosenp@gmail.com>
15 lines
539 B
Diff
15 lines
539 B
Diff
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -38,12 +38,6 @@ if (CMAKE_SYSTEM_NAME STREQUAL "Darwin")
|
|
target_compile_definitions(miniupnpc-private INTERFACE _DARWIN_C_SOURCE)
|
|
endif ()
|
|
|
|
-# Set compiler specific build flags
|
|
-if (CMAKE_COMPILER_IS_GNUCC AND NOT CMAKE_SYSTEM_NAME STREQUAL "AmigaOS")
|
|
- set(CMAKE_POSITION_INDEPENDENT_CODE ON)
|
|
- target_compile_options(miniupnpc-private INTERFACE -Wall)
|
|
-endif ()
|
|
-
|
|
# Suppress noise warnings
|
|
if (MSVC)
|
|
target_compile_definitions(miniupnpc-private INTERFACE _CRT_SECURE_NO_WARNINGS)
|