packages/net/apache/patches/010-reproducible-builds.patch
Sebastian Kemper 623ae46141 apache: bump to 2.4.41 & sync with master
This is a squash of the following cherry-picked commits:

14f4f0bef0
4e6bdd8a49
c8aba5113b
2d188fd37f
31e0d618e5
39e68309e8
a1472254db
d6476f30bb
258967b0d2
e94a08298e
6bd63d24f0
66bb68a7b6
d44ad09fcd

Short summary:

- version is bumped to 2.4.41
- httpd is renamed to apache2 to avoid overwriting of other servers (for
  instance busybox's httpd)
- the name apache2 is now also used for directories, for instance
  /etc/apache2 instead of /etc/apache
- a simple init script it added (/etc/init.d/apache2)
- a user "apache" is added upon package installation and used by default
- adds the Apache modules (in the main package as well as in additional
  packages)
- Makefile and patches are updated and cleaned
- adds myself as maintainer
- improves the cross-compile setup (via configure variables, patches &
  sed scripts)
- apxs is fixed up so that external modules can be added easily

For more details please check the individual commits provided above.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
2020-02-08 22:14:48 +01:00

40 lines
1.4 KiB
Diff

Description: Make builds reproducible
Don't use __DATE__ __TIME__. Use changelog date instead.
Sort exported symbols.
Author: Jean-Michel Vourgère <nirgal@debian.org>
Forwarded: no
Last-Update: 2015-08-11
--- a/server/buildmark.c
+++ b/server/buildmark.c
@@ -17,11 +17,7 @@
#include "ap_config.h"
#include "httpd.h"
-#if defined(__DATE__) && defined(__TIME__)
-static const char server_built[] = __DATE__ " " __TIME__;
-#else
-static const char server_built[] = "unknown";
-#endif
+static const char server_built[] = "";
AP_DECLARE(const char *) ap_get_server_built()
{
--- a/server/Makefile.in
+++ b/server/Makefile.in
@@ -1,3 +1,4 @@
+export LC_ALL = C
CLEAN_TARGETS = gen_test_char test_char.h \
ApacheCoreOS2.def httpd.exp export_files \
@@ -87,8 +88,8 @@ httpd.exp: exports.c export_vars.h
@echo "#! ." > $@
@echo "* This file was AUTOGENERATED at build time." >> $@
@echo "* Please do not edit by hand." >> $@
- $(CPP) $(ALL_CPPFLAGS) $(ALL_INCLUDES) exports.c | grep "ap_hack_" | grep -v apr_ | sed -e 's/^.*[)]\(.*\);$$/\1/' >> $@
- $(CPP) $(ALL_CPPFLAGS) $(ALL_INCLUDES) export_vars.h | grep -v apr_ | sed -e 's/^\#[^!]*//' | sed -e '/^$$/d' >> $@
+ $(CPP) $(ALL_CPPFLAGS) $(ALL_INCLUDES) exports.c | grep "ap_hack_" | grep -v apr_ | sed -e 's/^.*[)]\(.*\);$$/\1/' | sort >> $@
+ $(CPP) $(ALL_CPPFLAGS) $(ALL_INCLUDES) export_vars.h | grep -v apr_ | sed -e 's/^\#[^!]*//' | sed -e '/^$$/d' | sort >> $@
# developer stuff