Added a patch to remove BUILDCXXFLAGS. For some reason, TARGET_CXXFLAGS are leaking. Removed custom Build/Compile section. There's already PKG_INSTALL. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
557 B
Diff
11 lines
557 B
Diff
--- a/src/Makefile.am
|
|
+++ b/src/Makefile.am
|
|
@@ -765,7 +765,7 @@ cache_cf.o: cf_parser.cci
|
|
|
|
# cf_gen builds the configuration files.
|
|
cf_gen$(EXEEXT): $(cf_gen_SOURCES) $(cf_gen_DEPENDENCIES) cf_gen_defines.cci
|
|
- $(BUILDCXX) $(BUILDCXXFLAGS) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
|
+ $(BUILDCXX) -o $@ $(srcdir)/cf_gen.cc -I$(srcdir) -I$(top_builddir)/include/ -I$(top_builddir)/src
|
|
|
|
# squid.conf.default is built by cf_gen when making cf_parser.cci
|
|
squid.conf.default squid.conf.documented: cf_parser.cci
|