packages/net/kea/patches/001-fix-cross-compile.patch
Rosen Penev 222cad4ccc kea: fix compilation with libcxx
Boost headers try to include experimental/string_view when std is less
than c++17. This does not work ith libcxx where this header is not
present.

Refreshed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-10-31 18:23:28 -07:00

16 lines
401 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -580,10 +580,10 @@ AC_TRY_COMPILE([
usable_regex=
AC_MSG_CHECKING(for usuable C++11 regex)
-AC_TRY_RUN([
+AC_TRY_COMPILE([
#include <regex>
-#include <iostream>
-int main() {
+#include <iostream>],
+[int main() {
const std::regex regex(".*");
const std::string string = "This should match!";
const auto result = std::regex_search(string, regex);