packages/utils/qemu/patches/0005-pc-bios-fix-compilation-when-AS-is-actually-gcc-driv.patch
Yousong Zhou f40420d456 qemu: bump to version 5.0.0
The slirp patch was included in this QEMU release

CXX_DEPENDS is now added for all host components otherwise we get
errors like the following

  Package qemu-img is missing dependencies for the following libraries:
  libuClibc++.so.0
  Package qemu-nbd is missing dependencies for the following libraries:
  libuClibc++.so.0

--disable-bluez was removed from configure args because upstream
deprecated bluetooth subsystem since qemu v3.1 and remove the code in
commit 1d4ffe8dc77c ("Remove the core bluetooth code")

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
2020-05-11 17:02:16 +08:00

31 lines
1.3 KiB
Diff

From 905f3b7b6115f303f964b5aa1d3bc9bdae9d5bec Mon Sep 17 00:00:00 2001
From: Yousong Zhou <yszhou4tech@gmail.com>
Date: Sat, 24 Feb 2018 13:46:31 +0800
Subject: [PATCH] pc-bios: fix compilation when $(AS) is actually gcc driver
---
pc-bios/optionrom/Makefile | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/pc-bios/optionrom/Makefile b/pc-bios/optionrom/Makefile
index e33a24da0d..ce734e8202 100644
--- a/pc-bios/optionrom/Makefile
+++ b/pc-bios/optionrom/Makefile
@@ -34,7 +34,7 @@ endif
QEMU_INCLUDES += -I$(SRC_PATH)
Wa = -Wa,
-ASFLAGS += -32
+ASFLAGS += $(Wa)-32
QEMU_CFLAGS += $(call cc-c-option, $(QEMU_CFLAGS), $(Wa)-32)
build-all: multiboot.bin linuxboot.bin linuxboot_dma.bin kvmvapic.bin pvh.bin
@@ -44,7 +44,7 @@ build-all: multiboot.bin linuxboot.bin linuxboot_dma.bin kvmvapic.bin pvh.bin
%.o: %.S
- $(call quiet-command,$(CPP) $(QEMU_INCLUDES) $(QEMU_DGFLAGS) -c -o - $< | $(AS) $(ASFLAGS) -o $@,"AS","$(TARGET_DIR)$@")
+ $(call quiet-command,$(CPP) $(QEMU_INCLUDES) $(QEMU_DGFLAGS) -c -o - $< | $(AS) $(ASFLAGS) -o $@ -x assembler -,"AS","$(TARGET_DIR)$@")
pvh.img: pvh.o pvh_main.o
$(call quiet-command,$(LD) $(LDFLAGS_NOPIE) -m $(LD_I386_EMULATION) -T $(SRC_PATH)/pc-bios/optionrom/flat.lds -s -o $@ $^,"BUILD","$(TARGET_DIR)$@")