These meson checks rely on being able to run binaries. Just force them on. Reduces compiled size. Refreshed patches. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
488 B
Diff
11 lines
488 B
Diff
--- a/meson.build
|
||
+++ b/meson.build
|
||
@@ -94,7 +94,7 @@ installed_tests_template = files('templa
|
||
installed_tests_template_tap = files('template-tap.test.in')
|
||
|
||
# Don’t build the tests unless we can run them (either natively, in an exe wrapper, or by installing them for later use)
|
||
-build_tests = not meson.is_cross_build() or (meson.is_cross_build() and meson.has_exe_wrapper()) or installed_tests_enabled
|
||
+build_tests = false
|
||
|
||
add_project_arguments('-D_GNU_SOURCE', language: 'c')
|
||
|