packages/multimedia/crtmpserver/patches/010-link-crypt-for-lua.patch
Thomas Heil e236613a49 crtmpserver: import from packages, add myself as the maintainer
This adds the crtmpserver package from the old svn package tree. I adopt
the licensing information and will maintain the package in the future. I
also updated the package to the latest version and ensure that is
building on x86_64, ar71xx and avr32.

Signed-off-by: Thomas Heil <heil@terminal-consulting.de>
2014-06-23 18:53:18 +02:00

11 lines
509 B
Diff

--- a/builders/make/compile.mk
+++ b/builders/make/compile.mk
@@ -67,7 +67,7 @@ TINYXML_OBJS = $(TINYXML_SRCS:.cpp=.tiny
#common
COMMON_INCLUDE=$(LUA_INCLUDE) $(TINYXML_INCLUDE) $(SSL_INCLUDE) -I$(PROJECT_BASE_PATH)/sources/common/include
-COMMON_LIBS=$(SSL_LIB) -L$(OUTPUT_DYNAMIC) -llua -ltinyxml
+COMMON_LIBS=$(SSL_LIB) -L$(OUTPUT_DYNAMIC) -llua -ltinyxml -lcrypt
COMMON_SRCS = $(shell find $(PROJECT_BASE_PATH)/sources/common/src -type f -name "*.cpp")
COMMON_OBJS = $(COMMON_SRCS:.cpp=.common.o)