Added patches to fix meson compilation. Reworked flashrom.mk to work with meson. Several minor Makefile cleanups. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
632 B
Diff
11 lines
632 B
Diff
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -25,7 +25,7 @@ conf = configuration_data()
|
|
cc = meson.get_compiler('c')
|
|
add_project_arguments(cc.get_supported_arguments(warning_flags), language : 'c')
|
|
add_project_arguments('-D_DEFAULT_SOURCE', language : 'c')
|
|
-add_project_arguments('-D_POSIX_C_SOURCE', language : 'c') # required for fileno
|
|
+add_project_arguments('-D_POSIX_C_SOURCE=200809L', language : 'c') # required for fileno, nanosleep, and strndup
|
|
add_project_arguments('-D_BSD_SOURCE', language : 'c') # required for glibc < v2.19
|
|
add_project_arguments('-DFLASHROM_VERSION="' + meson.project_version() + '"', language : 'c')
|
|
|