packages/net/pdns/patches/100-pdns-disable-pdns.conf-dist.patch
Wout Bertrums 398cad2960 pdns: Update to 4.5.1
TARGET_CXX is added, because PowerDNS now uses C++17.

pdns.conf-dist is updated to the latest version shipped by PowerDNS.

010-time_t-check.patch, which is also used in pdns-recursor and dnsdist,
is added to patch out the check for 64-bit time_t,
because OpenWrt still supports 32-bit devices.

100-pdns-disable-pdns.conf-dist.patch is refreshed.

Signed-off-by: Wout Bertrums <wout@wbnet.eu>
2021-08-02 13:32:03 +02:00

37 lines
838 B
Diff

--- a/pdns/Makefile.am
+++ b/pdns/Makefile.am
@@ -71,7 +71,6 @@ CLEANFILES = \
backends/gsql/gsqlbackend.gcda \
backends/gsql/gsqlbackend.gcno \
backends/gsql/gsqlbackend.gcov \
- pdns.conf-dist \
apidocfiles.h
if !HAVE_API_SWAGGER_JSON
@@ -105,7 +104,6 @@ apidocfiles.h: api-swagger.yaml api-swag
./incfiles $^ > $@
noinst_SCRIPTS = pdns.init
-sysconf_DATA = pdns.conf-dist
sbin_PROGRAMS = pdns_server
bin_PROGRAMS = \
@@ -146,7 +144,7 @@ if IXFRDIST
bin_PROGRAMS += \
ixfrdist
-sysconf_DATA += \
+sysconf_DATA = \
ixfrdist.example.yml
endif
@@ -1299,9 +1297,6 @@ dnspcap2protobuf_LDADD = \
$(BOOST_PROGRAM_OPTIONS_LIBS) \
$(RT_LIBS)
-pdns.conf-dist: pdns_server
- $(AM_V_GEN)./pdns_server --config=default 2>/dev/null > $@
-
testrunner_SOURCES = \
arguments.cc \
auth-caches.cc auth-caches.hh \