packages/libs/glib2/patches/010-pcre.patch
Rosen Penev 5d27631d9f glib2: update to 2.74.0
Remove upstreamed patch and delete pointless one.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2022-09-22 01:20:17 -07:00

10 lines
314 B
Diff

--- a/glib/meson.build
+++ b/glib/meson.build
@@ -365,6 +365,7 @@ pcre2_static_args = []
if use_pcre2_static_flag
pcre2_static_args = ['-DPCRE2_STATIC']
+ pcre2 = pcre2.as_link_whole()
endif
glib_c_args = ['-DG_LOG_DOMAIN="GLib"', '-DGLIB_COMPILATION'] + pcre2_static_args + glib_hidden_visibility_args