Removed patches: * 027-bpo-43158-Use-configure-values-for-building-_uuid-ex.patch Already merged. * 029-disable-deprecation-warning.patch Packages should be patched/fixed to remove the use of distutils instead of disabling this warning. Also: * Updates PKG_LICENSE to use the correct SPDX license identifier * Fixes build for mipsel_24kc_24kf Fixes https://github.com/openwrt/packages/issues/17217. Signed-off-by: Jeffery To <jeffery.to@gmail.com>
12 lines
389 B
Diff
12 lines
389 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -830,7 +830,8 @@ class PyBuildExt(build_ext):
|
|
# only change this for cross builds for 3.3, issues on Mageia
|
|
if CROSS_COMPILING:
|
|
self.add_cross_compiling_paths()
|
|
- self.add_multiarch_paths()
|
|
+ else:
|
|
+ self.add_multiarch_paths()
|
|
self.add_ldflags_cppflags()
|
|
|
|
def init_inc_lib_dirs(self):
|