packages/net/kea/patches/001-fix-cross-compile.patch
Rosen Penev f478209bce
kea: Specify OpenSSL location
Some buildbots are failing on this.

Refreshed patches.

Replace -fPIC with $(FPIC)

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-04-07 15:49:43 -07:00

16 lines
414 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -580,10 +580,10 @@ AC_TRY_COMPILE([
AC_MSG_RESULT(no))
AC_MSG_CHECKING(for usuable C++11 regex)
-AC_TRY_RUN([
+AC_TRY_COMPILE([
#include <regex>
-#include <iostream>
-int main() {
+#include <iostream>],
+[int main() {
const std::regex regex(".*");
const std::string string = "This should match!";
const auto result = std::regex_search(string, regex);