Added Fedora patch to fix compilation. Added python3 dependency as it seems it's needed now. Replaced custom boost 1.73 patch with upstream one. Removed CFLAG that was supposed to fix this but didn't do anything. Removed nls.mk. telldus-core was fixed to not require iconv. Signed-off-by: Rosen Penev <rosenp@gmail.com>
27 lines
922 B
Diff
27 lines
922 B
Diff
--- a/hardware/plugins/DelayedLink.h
|
|
+++ b/hardware/plugins/DelayedLink.h
|
|
@@ -14,6 +14,16 @@
|
|
#include <frameobject.h>
|
|
#include "../../main/Helper.h"
|
|
|
|
+#ifndef _Py_DEC_REFTOTAL
|
|
+ /* _Py_DEC_REFTOTAL macro has been removed from Python 3.9 by:
|
|
+ https://github.com/python/cpython/commit/49932fec62c616ec88da52642339d83ae719e924 */
|
|
+# ifdef Py_REF_DEBUG
|
|
+# define _Py_DEC_REFTOTAL _Py_RefTotal--
|
|
+# else
|
|
+# define _Py_DEC_REFTOTAL
|
|
+# endif
|
|
+#endif
|
|
+
|
|
#if PY_VERSION_HEX >= 0x030800f0
|
|
static inline void
|
|
py3__Py_DECREF(const char *filename, int lineno, PyObject *op)
|
|
@@ -195,6 +205,7 @@ namespace Plugins {
|
|
if (!shared_lib_) shared_lib_ = LoadLibrary("python34.dll");
|
|
# endif
|
|
#else
|
|
+ if (!shared_lib_) FindLibrary("python3.9", true);
|
|
if (!shared_lib_) FindLibrary("python3.8", true);
|
|
if (!shared_lib_) FindLibrary("python3.7", true);
|
|
if (!shared_lib_) FindLibrary("python3.6", true);
|