packages/lang/python/micropython/patches/040-extmod-use-external-mbedtls.patch
Jeffery To b9d10fc3e6 micropython: Update to 1.17, reorganize package
Previous versions used a bundled version of the axTLS library. The
MicroPython project maintains their own fork[1], as development of the
library appears to have stopped (the last release was version 2.1.5 in
2019[2]).

This replaces the use of axTLS with two variants, one using mbedTLS and
one with no TLS support (and no upip, as it uses the ussl module). The
external mbedTLS patch (040-extmod-use-external-mbedtls.patch) comes
from Debian[3].

This also sets myself as the maintainer.

[1]: https://github.com/micropython/axtls
[2]: https://sourceforge.net/projects/axtls/files/
[3]: https://salsa.debian.org/yangfl-guest/micropython/-/blob/master/debian/patches/0006-extmod-Use-system-mbedtls.patch

Signed-off-by: Jeffery To <jeffery.to@gmail.com>
2022-01-11 16:24:13 -08:00

95 lines
1.7 KiB
Diff

From 9717338f1917fa5db63fe7c9758639417ab06f61 Mon Sep 17 00:00:00 2001
From: yangfl <yangfl@users.noreply.github.com>
Date: Mon, 4 Jan 2021 23:09:41 +0800
Subject: [PATCH 06/10] extmod: Use system mbedtls
---
extmod/extmod.mk | 77 ++----------------------------------------------
1 file changed, 2 insertions(+), 75 deletions(-)
--- a/extmod/extmod.mk
+++ b/extmod/extmod.mk
@@ -66,81 +66,8 @@ SRC_MOD += $(addprefix $(AXTLS_DIR)/,\
crypto/sha1.c \
)
else ifeq ($(MICROPY_SSL_MBEDTLS),1)
-MBEDTLS_DIR = lib/mbedtls
-CFLAGS_MOD += -DMICROPY_SSL_MBEDTLS=1 -I$(TOP)/$(MBEDTLS_DIR)/include
-SRC_MOD += $(addprefix $(MBEDTLS_DIR)/library/,\
- aes.c \
- aesni.c \
- arc4.c \
- asn1parse.c \
- asn1write.c \
- base64.c \
- bignum.c \
- blowfish.c \
- camellia.c \
- ccm.c \
- certs.c \
- chacha20.c \
- chachapoly.c \
- cipher.c \
- cipher_wrap.c \
- cmac.c \
- ctr_drbg.c \
- debug.c \
- des.c \
- dhm.c \
- ecdh.c \
- ecdsa.c \
- ecjpake.c \
- ecp.c \
- ecp_curves.c \
- entropy.c \
- entropy_poll.c \
- error.c \
- gcm.c \
- havege.c \
- hmac_drbg.c \
- md2.c \
- md4.c \
- md5.c \
- md.c \
- md_wrap.c \
- oid.c \
- padlock.c \
- pem.c \
- pk.c \
- pkcs11.c \
- pkcs12.c \
- pkcs5.c \
- pkparse.c \
- pk_wrap.c \
- pkwrite.c \
- platform.c \
- platform_util.c \
- poly1305.c \
- ripemd160.c \
- rsa.c \
- rsa_internal.c \
- sha1.c \
- sha256.c \
- sha512.c \
- ssl_cache.c \
- ssl_ciphersuites.c \
- ssl_cli.c \
- ssl_cookie.c \
- ssl_srv.c \
- ssl_ticket.c \
- ssl_tls.c \
- timing.c \
- x509.c \
- x509_create.c \
- x509_crl.c \
- x509_crt.c \
- x509_csr.c \
- x509write_crt.c \
- x509write_csr.c \
- xtea.c \
- )
+CFLAGS_MOD += -DMICROPY_SSL_MBEDTLS=1
+LDFLAGS_MOD += -lmbedx509 -lmbedtls -lmbedcrypto
endif
endif