Modified to use meson as upstream has abandoned autotools. Added license information. Cleaned up Makefile for consistency between packages. Added hack to compile static libs. Removed old patches and add new ones. Removed BUILD_PARALLEL options. These are default with ninja/meson. Removed gettext build dependencies. glib2 now includes its own solution. Added patch to remove distutils host dependency. Signed-off-by: Rosen Penev <rosenp@gmail.com>
20 lines
742 B
Diff
20 lines
742 B
Diff
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -2137,16 +2137,10 @@ endif
|
|
|
|
glib_conf.set('HAVE_PROC_SELF_CMDLINE', have_proc_self_cmdline)
|
|
|
|
-python = import('python').find_installation('python3')
|
|
+python = 'python3'
|
|
# used for '#!/usr/bin/env <name>'
|
|
python_name = 'python3'
|
|
|
|
-python_version = python.language_version()
|
|
-python_version_req = '>=3.5'
|
|
-if not python_version.version_compare(python_version_req)
|
|
- error('Requires Python @0@, @1@ found.'.format(python_version_req, python_version))
|
|
-endif
|
|
-
|
|
# Determine which user environment-dependent files that we want to install
|
|
have_bash = find_program('bash', required : false).found() # For completion scripts
|
|
have_sh = find_program('sh', required : false).found() # For glib-gettextize
|