packages/net/boinc/patches/001-avoidExtraDependencies
Steffen Möller e554dcf1d2 Boinc: Avoiding unexpected dependencies
In reaction to a comment by @hnyman in
https://github.com/openwrt/packages/pull/11768#issuecomment-610513948
on BOINC embracing too many libraries it finds on its build
host, the inclusion of the freetype library is now excluded
by an embracing "if" statement.

The patch is presented to BOINC upstream at
https://github.com/BOINC/boinc/pull/3578

Signed-off-by: Steffen Möller <moeller@debian.org>
2020-04-08 07:17:09 +02:00

15 lines
713 B
Text

Index: boinc-client_release-7.16-7.16.5/configure.ac
===================================================================
--- boinc-client_release-7.16-7.16.5.orig/configure.ac
+++ boinc-client_release-7.16-7.16.5/configure.ac
@@ -506,8 +506,10 @@ SAH_CHECK_LIB([dl], [dlopen],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
SAH_CHECK_LIB([nsl], [gethostbyname],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
+if test "${enable_manager}" = yes ; then
SAH_CHECK_LIB([freetype], [fopen],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
+fi
SAH_CHECK_LIB([socket], [bind],
[BOINC_EXTRA_LIBS="${BOINC_EXTRA_LIBS} ${sah_lib_last}"])
SAH_CHECK_LIB([z], [gzopen],