packages/lang/python/python3/patches/015-abort-on-failed-modules.patch
Alexandru Ardelean cc332fddaa python3: bump to version 3.9.0
Refreshed patches.

Dropped 'patches-setuptools/004-site-patch.patch'
Does not apply anymore. Setuptools has removed site.py support:
   https://github.com/pypa/setuptools/issues/2165
If this is still needed, we may need to re-think it's implementation.

Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
2020-10-19 11:01:12 +03:00

10 lines
322 B
Diff

--- a/setup.py
+++ b/setup.py
@@ -536,6 +536,7 @@ class PyBuildExt(build_ext):
print("Failed to build these modules:")
print_three_column(failed)
print()
+ if CROSS_COMPILING: sys.exit(1)
if self.failed_on_import:
failed = self.failed_on_import[:]