Refreshed patches. Dropped 'patches-setuptools/004-site-patch.patch' Does not apply anymore. Setuptools has removed site.py support: https://github.com/pypa/setuptools/issues/2165 If this is still needed, we may need to re-think it's implementation. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
22 lines
845 B
Diff
22 lines
845 B
Diff
--- a/configure
|
|
+++ b/configure
|
|
@@ -15308,7 +15308,7 @@ $as_echo_n "checking ABIFLAGS... " >&6;
|
|
$as_echo "$ABIFLAGS" >&6; }
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: checking SOABI" >&5
|
|
$as_echo_n "checking SOABI... " >&6; }
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
{ $as_echo "$as_me:${as_lineno-$LINENO}: result: $SOABI" >&5
|
|
$as_echo "$SOABI" >&6; }
|
|
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -4749,7 +4749,7 @@ AC_SUBST(SOABI)
|
|
AC_MSG_CHECKING(ABIFLAGS)
|
|
AC_MSG_RESULT($ABIFLAGS)
|
|
AC_MSG_CHECKING(SOABI)
|
|
-SOABI='cpython-'`echo $VERSION | tr -d .`${ABIFLAGS}${PLATFORM_TRIPLET:+-$PLATFORM_TRIPLET}
|
|
+SOABI='cpython-'`echo $VERSION | tr -d .`
|
|
AC_MSG_RESULT($SOABI)
|
|
|
|
# Release and debug (Py_DEBUG) ABI are compatible, but not Py_TRACE_REFS ABI
|