Update bluez to 5.49 Fix issue https://github.com/openwrt/packages/issues/1497 Fix issue https://github.com/openwrt/packages/issues/1503 Cherry pick patches from Alpine Linux repo Apply --gc-sections, saves about 500kbyte Drop audio.conf (not needed and deprecated) Remove bluetooth.dbus as upstream supplies a working copy Based on patch provided by Johnny Vogels https://github.com/openwrt/packages/pull/5937 Source: https://git.alpinelinux.org/cgit/aports/commit/main/bluez/fix-endianness.patch?id=1c6991b32a22be2c905cc1709be1376c4e79e451 https://git.alpinelinux.org/cgit/aports/commit/main/bluez/bluez-5.40-obexd_without_systemd-1.patch?id=980b2d04ae4339594701b33cf9460757c989c94c Signed-off-by: Daniel Engberg <daniel.engberg.lists@pyret.net>
57 lines
2.7 KiB
Diff
57 lines
2.7 KiB
Diff
--- a/Makefile.in 2017-09-14 11:47:06.000000000 +0200
|
|
+++ b/Makefile.in 2017-09-15 02:52:39.315926972 +0200
|
|
@@ -2472,7 +2472,7 @@
|
|
@CLIENT_TRUE@ client/gatt.h client/gatt.c
|
|
|
|
@CLIENT_TRUE@client_bluetoothctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
|
-@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
|
|
+@CLIENT_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
|
|
|
|
@MESH_TRUE@mesh_meshctl_SOURCES = mesh/main.c \
|
|
@MESH_TRUE@ mesh/mesh-net.h \
|
|
@@ -2491,7 +2491,7 @@
|
|
|
|
@MESH_TRUE@mesh_meshctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
|
@MESH_TRUE@ lib/libbluetooth-internal.la \
|
|
-@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline
|
|
+@MESH_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -ljson-c -lreadline -lncurses
|
|
|
|
@MONITOR_TRUE@monitor_btmon_SOURCES = monitor/main.c monitor/bt.h \
|
|
@MONITOR_TRUE@ monitor/display.h monitor/display.c \
|
|
@@ -2747,7 +2747,7 @@
|
|
@READLINE_TRUE@ tools/obex-client-tool.c
|
|
|
|
@READLINE_TRUE@tools_obex_client_tool_LDADD = lib/libbluetooth-internal.la \
|
|
-@READLINE_TRUE@ @GLIB_LIBS@ -lreadline
|
|
+@READLINE_TRUE@ @GLIB_LIBS@ -lreadline -lncurses
|
|
|
|
@READLINE_TRUE@tools_obex_server_tool_SOURCES = $(gobex_sources) $(btio_sources) \
|
|
@READLINE_TRUE@ tools/obex-server-tool.c
|
|
@@ -2756,15 +2756,15 @@
|
|
@READLINE_TRUE@tools_bluetooth_player_SOURCES = tools/bluetooth-player.c
|
|
@READLINE_TRUE@tools_bluetooth_player_LDADD = gdbus/libgdbus-internal.la \
|
|
@READLINE_TRUE@ src/libshared-glib.la \
|
|
-@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
|
|
+@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
|
|
|
|
@READLINE_TRUE@tools_obexctl_SOURCES = tools/obexctl.c
|
|
@READLINE_TRUE@tools_obexctl_LDADD = gdbus/libgdbus-internal.la src/libshared-glib.la \
|
|
-@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline
|
|
+@READLINE_TRUE@ @GLIB_LIBS@ @DBUS_LIBS@ -lreadline -lncurses
|
|
|
|
@READLINE_TRUE@tools_btmgmt_SOURCES = tools/btmgmt.c src/uuid-helper.c client/display.c
|
|
@READLINE_TRUE@tools_btmgmt_LDADD = lib/libbluetooth-internal.la src/libshared-mainloop.la \
|
|
-@READLINE_TRUE@ -lreadline
|
|
+@READLINE_TRUE@ -lreadline -lncurses
|
|
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_SOURCES = attrib/gatttool.c attrib/att.c attrib/gatt.c \
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@ attrib/gattrib.c btio/btio.c \
|
|
@@ -2773,7 +2773,7 @@
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@ client/display.h
|
|
|
|
@DEPRECATED_TRUE@@READLINE_TRUE@attrib_gatttool_LDADD = lib/libbluetooth-internal.la \
|
|
-@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline
|
|
+@DEPRECATED_TRUE@@READLINE_TRUE@ src/libshared-glib.la @GLIB_LIBS@ -lreadline -lncurses
|
|
|
|
@CUPS_TRUE@cupsdir = $(libdir)/cups/backend
|
|
@CUPS_TRUE@profiles_cups_bluetooth_SOURCES = profiles/cups/main.c \
|