Dropped patches: 0004-Replace-EVP_CIPHER_CTX_cleanup-with-EVP_CIPHER_CTX_r.patch 0005-Switch-get_-Update-APIs-to-get0.patch Reworked patches: 0001-Add-new-ASN1_STRING_get0_data-API.patch 0006-Add-X509_STORE_CTX_trusted_stack-compatibility-macro.patch These 2 require that we keep only the CUSTOMIZATIONS stuff for now. Maybe later we can drop this. Ran 'make package/python-cryptography/refresh'. Added patch: 0004-disable-rust.patch upstream did a sloppy job with the CRYPTOGRAPHY_DONT_BUILD_RUST logic; we need to patch it, to make sure the setuptools-rust isn't installed. We may need to carry this patch in our tree for a bit longer than upstream, because in newer versions, CRYPTOGRAPHY_DONT_BUILD_RUST logic gets removed. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
20 lines
498 B
Diff
20 lines
498 B
Diff
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -11,7 +11,7 @@ import sys
|
|
from setuptools import find_packages, setup
|
|
|
|
try:
|
|
- from setuptools_rust import RustExtension
|
|
+ pass
|
|
except ImportError:
|
|
print(
|
|
"""
|
|
@@ -45,7 +45,7 @@ setuptools_rust = "setuptools-rust>=0.11
|
|
install_requirements = ["cffi>=1.12"]
|
|
setup_requirements = install_requirements + [setuptools_rust]
|
|
|
|
-if os.environ.get("CRYPTOGRAPHY_DONT_BUILD_RUST"):
|
|
+if True:
|
|
rust_extensions = []
|
|
else:
|
|
rust_extensions = [
|