packages/net/zerotier/patches/0004-accept-external-linker-flags.patch
Deng Qingfang 4a3e3fb286 zerotier: remove ARM32 conservative CFLAGS
OpenWrt toolchains already use correct CFLAGS for every ARM target
There is no reason to use conservative CFLAGS now
It also causes compile error with GCC 9.1.0

Signed-off-by: Deng Qingfang <dengqf6@mail2.sysu.edu.cn>
2019-06-08 01:32:29 +08:00

25 lines
736 B
Diff

From a2cf8bf645d25f18cbc2ed7ad4b9a25725811afd Mon Sep 17 00:00:00 2001
From: Moritz Warning <moritzwarning@web.de>
Date: Wed, 2 May 2018 16:06:46 +0200
Subject: [PATCH 4/4] accept external linker flags
---
make-linux.mk | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/make-linux.mk b/make-linux.mk
index 49e14f70..8e766bfb 100644
--- a/make-linux.mk
+++ b/make-linux.mk
@@ -67,7 +67,7 @@ else
override CFLAGS+=-Wall -Wno-deprecated -pthread $(INCLUDES) -DNDEBUG $(DEFS)
CXXFLAGS?=-O3 -fstack-protector
override CXXFLAGS+=-Wall -Wno-deprecated -std=c++11 -pthread $(INCLUDES) -DNDEBUG $(DEFS)
- LDFLAGS=-Wl,-z,relro,-z,now
+ LDFLAGS+=-Wl,-z,relro,-z,now
STRIP?=strip
STRIP+=--strip-all
endif
--
2.17.0