Switch to git tarball as the meson files did not get added to the official one. Backport busybox style binaries. Saves on size. Signed-off-by: Rosen Penev <rosenp@gmail.com>
69 lines
1.6 KiB
Diff
69 lines
1.6 KiB
Diff
From 3281f325c820a72057ea639e0d11ad68d5703b43 Mon Sep 17 00:00:00 2001
|
|
From: Rosen Penev <rosenp@gmail.com>
|
|
Date: Thu, 6 Oct 2022 18:07:01 -0700
|
|
Subject: [PATCH] ksmbd-tools: run meson through muon analyze
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Mostly unused variable removals. Removed pointless [] in
|
|
include_directories.
|
|
|
|
Signed-off-by: Rosen Penev <rosenp@gmail.com>
|
|
Acked-by: Atte Heikkilä <atteh.mailbox@gmail.com>
|
|
Signed-off-by: Namjae Jeon <linkinjeon@kernel.org>
|
|
---
|
|
addshare/meson.build | 2 +-
|
|
adduser/meson.build | 2 +-
|
|
control/meson.build | 2 +-
|
|
meson.build | 4 ++--
|
|
mountd/meson.build | 2 +-
|
|
5 files changed, 6 insertions(+), 6 deletions(-)
|
|
|
|
--- a/addshare/meson.build
|
|
+++ b/addshare/meson.build
|
|
@@ -1,4 +1,4 @@
|
|
-addshare = executable(
|
|
+executable(
|
|
'ksmbd.addshare',
|
|
'share_admin.c',
|
|
'addshare.c',
|
|
--- a/adduser/meson.build
|
|
+++ b/adduser/meson.build
|
|
@@ -1,4 +1,4 @@
|
|
-adduser = executable(
|
|
+executable(
|
|
'ksmbd.adduser',
|
|
'md4_hash.c',
|
|
'user_admin.c',
|
|
--- a/control/meson.build
|
|
+++ b/control/meson.build
|
|
@@ -1,4 +1,4 @@
|
|
-control = executable(
|
|
+executable(
|
|
'ksmbd.control',
|
|
'control.c',
|
|
dependencies: [
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -13,10 +13,10 @@ exec awk '/define KSMBD_TOOLS_VERSION /
|
|
meson_version: '>= 0.51.0',
|
|
)
|
|
|
|
-tools_incdir = include_directories([
|
|
+tools_incdir = include_directories(
|
|
'.',
|
|
'include',
|
|
-])
|
|
+)
|
|
|
|
glib_dep = dependency(
|
|
'glib-2.0',
|
|
--- a/mountd/meson.build
|
|
+++ b/mountd/meson.build
|
|
@@ -1,4 +1,4 @@
|
|
-mountd = executable(
|
|
+executable(
|
|
'ksmbd.mountd',
|
|
'worker.c',
|
|
'ipc.c',
|