packages/libs/librsocket-cpp/patches/103-boost.patch
Rosen Penev 164e706f9d
librsocket-cpp: Update to 2019-09-22
Added URLs.

Added needed Boost patch.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2019-09-22 18:11:23 -07:00

12 lines
421 B
Diff

--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -194,6 +194,9 @@ find_package(Gflags REQUIRED)
# find glog::glog to satisfy the folly dep.
find_package(Glog REQUIRED)
+find_package(Boost REQUIRED COMPONENTS system thread filesystem regex context
+ date_time program_options)
+
include_directories(SYSTEM ${OPENSSL_INCLUDE_DIR})
include_directories(SYSTEM ${GFLAGS_INCLUDE_DIR})