packages/libs/libftdi1/patches/101-use-findSWIG.patch
Eneas U de Queiroz 0e9e060775 libftdi1: Fix compilation with cmake 3.12
Applied a patch submitted upstream that fixes a compilation error with
cmake >= 3.12 Error: Unable to find 'swig.swg' [...] 'python.swg'

Signed-off-by: Eneas U de Queiroz <cote2004-github@yahoo.com>
2018-07-31 18:12:28 -03:00

11 lines
404 B
Diff

--- a/python/CMakeLists.txt
+++ b/python/CMakeLists.txt
@@ -3,7 +3,7 @@ option ( LINK_PYTHON_LIBRARY "Link again
if ( PYTHON_BINDINGS )
# workaround for cmake bug #0013449
- if ( NOT DEFINED CMAKE_FIND_ROOT_PATH )
+ if ( NOT DEFINED CMAKE_FIND_ROOT_PATH OR CMAKE_VERSION VERSION_GREATER_EQUAL 3.0.0 )
find_package ( SWIG )
else ()
find_program ( SWIG_EXECUTABLE NAMES swig2.0 swig )