Remove various outdated patches. No more uClibc and distutils is a requirement. Compile host libraries statically. Size is not a concern there. Also avoids rpath hacks. Disable NLS as well. Avoids gettext dependencies. Add libpcre dependency. Seems to be a requirement now. Signed-off-by: Rosen Penev <rosenp@gmail.com>
11 lines
473 B
Diff
11 lines
473 B
Diff
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -949,7 +949,7 @@ if host_system == 'windows' and (cc.get_
|
|
glib_conf.set('HAVE_C99_SNPRINTF', false)
|
|
glib_conf.set('HAVE_C99_VSNPRINTF', false)
|
|
glib_conf.set('HAVE_UNIX98_PRINTF', false)
|
|
-elif not cc_can_run and host_system in ['ios', 'darwin']
|
|
+elif true
|
|
# All these are true when compiling natively on macOS, so we should use good
|
|
# defaults when building for iOS and tvOS.
|
|
glib_conf.set('HAVE_C99_SNPRINTF', true)
|