packages/lang/ruby/patches/100-musl.patch
Luiz Angelo Daros de Luca 1b41e8f641 ruby: update to 3.0.2
This release fixes some bugs and these vulnerabilities:

* CVE-2021-31810: Trusting FTP PASV responses vulnerability in Net::FTP
* CVE-2021-32066: A StartTLS stripping vulnerability in Net::IMAP
* CVE-2021-31799: A command injection vulnerability in RDoc

Signed-off-by: Luiz Angelo Daros de Luca <luizluca@gmail.com>
2021-07-15 14:44:15 -03:00

17 lines
550 B
Diff

Rebased on https://patch-diff.githubusercontent.com/raw/ruby/ruby/pull/2995.patch
which was originally based on this file.
--- a/configure.ac
+++ b/configure.ac
@@ -2471,7 +2471,10 @@ AS_CASE([$rb_cv_coroutine], [yes|''], [
rb_cv_coroutine=copy
],
[
- rb_cv_coroutine=ucontext
+ AC_CHECK_FUNCS([getcontext swapcontext makecontext],
+ [rb_cv_coroutine=ucontext],
+ [rb_cv_coroutine=copy; break]
+ )
]
)
AC_MSG_RESULT(${rb_cv_coroutine})