packages/libs/libcap/patches/300-uclibc-ng.patch
Rosen Penev 2f957ddc30
libcap: update to 2.33
Added a compatibility fix for musl.

Refreshed patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
2020-03-09 15:25:20 -07:00

11 lines
448 B
Diff

--- a/tests/Makefile
+++ b/tests/Makefile
@@ -32,7 +32,7 @@ run_libcap_psx_test: libcap_psx_test
./libcap_psx_test
libcap_psx_test: libcap_psx_test.c $(DEPS)
- $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create --static
+ $(CC) $(CFLAGS) $(IPATH) $< -o $@ $(LIBCAPLIB) $(LIBPSXLIB) -Wl,-wrap,pthread_create
run_libcap_launch_test: libcap_launch_test libcap_psx_launch_test noop
sudo ./libcap_launch_test