packages/net/snort/patches/100-autoconf-fixes.patch
Jo-Philipp Wich eaf4652760 snort: fix build with CONFIG_PKG_CHECK_FORMAT_SECURITY
The configure script incorrectly mangles `CFLAGS` by attempting to remove
`-Werror` from it, thus turning `-Werror=format-security` into just
`=format-security` which will cause subsequent autoconf tests to fail.

Patch out the custom `CFLAGS` mangling to fix the build.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
2015-06-25 17:29:22 +02:00

17 lines
541 B
Diff

--- a/configure.in
+++ b/configure.in
@@ -11,14 +11,6 @@ AM_INIT_AUTOMAKE(snort,2.9.7.2)
NO_OPTIMIZE="no"
ADD_WERROR="no"
-# Test for -Werror and sed it out for now since some of the auto tests,
-# for example AC_CHECK_LIB, will fail because of
-# warning: conflicting types for built-in function <func>
-if eval "echo $CFLAGS | grep -e -Werror"; then
- CFLAGS=`echo $CFLAGS | sed -e "s/-Werror//g"`
- ADD_WERROR="yes"
-fi
-
# Disable annoying practice of recursively re-running the autotools
AM_MAINTAINER_MODE
AC_PROG_CC_STDC