packages/net/kea/patches/001-fix-cross-compile.patch
BangLang Huang 28e8dc578f kea: add new package
Kea is an open source DHCPv4/DHCPv6 server being developed by
Internet Systems Consortium. Kea is a high-performance, extensible
DHCP server engine that is designed to be easily modified and extended
with hooks libraries.

Kea is free open source, and we welcome community engagement, via the
Kea-users mailing list, this wiki, and our Github
repository. There is a small core team of dedicated software engineers
developing it and we need your contributions and support
contracts to support them.

DHCP Standardization efforts: The lead developer on KEA is
co-chair of the Dynamic Host Configuration working group in the
IETF. We are committed to providing a standards-compliant
implementation and are closely tracking developments in this working
group and evaluating them for inclusion in KEA.

wiki : http://kea.isc.org/wiki
official : https://www.isc.org/kea/

Signed-off-by: BangLang Huang <banglang.huang@foxmail.com>
2019-04-03 13:58:44 +08:00

16 lines
414 B
Diff

--- a/configure.ac
+++ b/configure.ac
@@ -594,10 +594,10 @@ AC_TRY_COMPILE([
AC_MSG_RESULT(no))
AC_MSG_CHECKING(for usuable C++11 regex)
-AC_TRY_RUN([
+AC_TRY_COMPILE([
#include <regex>
-#include <iostream>
-int main() {
+#include <iostream>],
+[int main() {
const std::regex regex(".*");
const std::string string = "This should match!";
const auto result = std::regex_search(string, regex);